aboutsummaryrefslogtreecommitdiff
path: root/packages/dev-lang/clojure/clojure-1.4.0.exheres-0
diff options
context:
space:
mode:
authorGuillermo Ramos2012-08-17 01:30:58 +0000
committerGuillermo Ramos2012-08-17 01:30:58 +0000
commitc375c601cfb1665b948dda0a69afed921ad60de6 (patch)
tree573744831407607e2a4604d000516ed857262560 /packages/dev-lang/clojure/clojure-1.4.0.exheres-0
downloadexheres-c375c601cfb1665b948dda0a69afed921ad60de6.tar.gz
First commit
Diffstat (limited to 'packages/dev-lang/clojure/clojure-1.4.0.exheres-0')
-rw-r--r--packages/dev-lang/clojure/clojure-1.4.0.exheres-048
1 files changed, 48 insertions, 0 deletions
diff --git a/packages/dev-lang/clojure/clojure-1.4.0.exheres-0 b/packages/dev-lang/clojure/clojure-1.4.0.exheres-0
new file mode 100644
index 0000000..22e5cea
--- /dev/null
+++ b/packages/dev-lang/clojure/clojure-1.4.0.exheres-0
@@ -0,0 +1,48 @@
+# Copyright 2012 Guillermo Ramos
+# Distributed under the terms of the GNU General Public License v2
+# Based in part upon 'clojure-1.4.0.ebuild' from Gentoo, which is:
+# Copyright 1999-2012 Gentoo Foundation
+
+require ant
+
+SUMMARY="Clojure is a dynamic programming language that targets the Java Virtual Machine"
+HOMEPAGE="http://clojure.org/"
+DOWNLOADS="https://github.com/clojure/clojure/tarball/${PNV} -> ${PNV}.tar.gz"
+
+LICENCES="EPL-1.0"
+PLATFORMS="amd64 x86"
+SLOT="1.4"
+
+DEPENDENCIES="
+ build:
+ virtual/jdk[>=1.5]
+ run:
+ virtual/jre[>=1.5]
+"
+
+
+SHORT_PNV=${PN}-${SLOT}
+
+WORK=${WORKBASE}/clojure-clojure-8306949
+
+ANT_SRC_COMPILE_PARAMS=( jar )
+ANT_SRC_TEST_PARAMS=( test )
+
+
+src_prepare() { :; }
+
+src_install() {
+ edo mv ${PNV}.jar ${PN}.jar
+
+ insinto /usr/share/${SHORT_PNV}
+ doins ${PN}.jar
+
+ exeinto /usr/bin/
+ doexe ${FILES}/${SHORT_PNV}
+
+ # Is this ethical?
+ dosym /usr/bin/${SHORT_PNV} /usr/bin/${PN}
+
+ dodoc changes.md readme.txt
+}
+