summaryrefslogtreecommitdiff
path: root/dev-python/hvac/hvac-0.10.5.ebuild
diff options
context:
space:
mode:
authorGuillermo Ramos2020-10-31 10:52:21 +0100
committerGuillermo Ramos2020-10-31 10:52:21 +0100
commitab467ff9f743bcbc3191ee94aeecd56a40a3f46c (patch)
tree23fff79f1b13bdf69ca83469774ff3bdd1126f77 /dev-python/hvac/hvac-0.10.5.ebuild
parent586fa0ea4c2cff63c2ea62d37da4a4c8a0eadfc8 (diff)
downloadgentoo-overlay-ab467ff9f743bcbc3191ee94aeecd56a40a3f46c.tar.gz
Bump pyhcl + hvac
Diffstat (limited to 'dev-python/hvac/hvac-0.10.5.ebuild')
-rw-r--r--dev-python/hvac/hvac-0.10.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/hvac/hvac-0.10.5.ebuild b/dev-python/hvac/hvac-0.10.5.ebuild
new file mode 100644
index 0000000..a8f1847
--- /dev/null
+++ b/dev-python/hvac/hvac-0.10.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2/3 client for HashiCorp Vault"
+HOMEPAGE="https://github.com/ianunruh/hvac"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=dev-python/pyhcl-0.3.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.21[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ app-admin/vault
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/semantic_version[${PYTHON_USEDEP}] )"
+
+RESTRICT="test" # need running vault
+
+python_test() {
+ nosetests -v || die
+}