summaryrefslogtreecommitdiff
path: root/dev-python/hvac/hvac-0.9.2.ebuild
diff options
context:
space:
mode:
authorGuillermo Ramos2020-10-22 22:47:43 +0200
committerGuillermo Ramos2020-10-22 22:47:43 +0200
commit1007a2fd4ae2228b4f04ee3800a86e79b9c1455c (patch)
tree440f9ad4bc4433bee7fbedf90457d983fc808cc8 /dev-python/hvac/hvac-0.9.2.ebuild
downloadgentoo-overlay-1007a2fd4ae2228b4f04ee3800a86e79b9c1455c.tar.gz
First commit
Diffstat (limited to 'dev-python/hvac/hvac-0.9.2.ebuild')
-rw-r--r--dev-python/hvac/hvac-0.9.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/hvac/hvac-0.9.2.ebuild b/dev-python/hvac/hvac-0.9.2.ebuild
new file mode 100644
index 0000000..c30f4ec
--- /dev/null
+++ b/dev-python/hvac/hvac-0.9.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2/3 client for HashiCorp Vault"
+HOMEPAGE="https://github.com/ianunruh/hvac"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">dev-python/pyhcl-0.3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ app-admin/vault
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/semantic_version[${PYTHON_USEDEP}] )"
+
+RESTRICT="test" # need running vault
+
+python_test() {
+ nosetests -v || die
+}