summaryrefslogtreecommitdiff
path: root/dev-python/hvac/hvac-0.10.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hvac/hvac-0.10.5.ebuild')
-rw-r--r--dev-python/hvac/hvac-0.10.5.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/hvac/hvac-0.10.5.ebuild b/dev-python/hvac/hvac-0.10.5.ebuild
deleted file mode 100644
index 3b9cb36..0000000
--- a/dev-python/hvac/hvac-0.10.5.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python 2/3 client for HashiCorp Vault"
-HOMEPAGE="https://github.com/ianunruh/hvac"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-RDEPEND=">=dev-python/pyhcl-0.3.10[${PYTHON_USEDEP}]
- >=dev-python/requests-2.21[${PYTHON_USEDEP}]
- >=dev-python/six-1.5[${PYTHON_USEDEP}]"
-BDEPEND="test? (
- ${RDEPEND}
- app-admin/vault
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/semantic_version[${PYTHON_USEDEP}]
-)"
-
-RESTRICT="test" # need running vault
-
-python_test() {
- nosetests -v || die
-}