summaryrefslogtreecommitdiff
path: root/dev-python/pyhcl/pyhcl-0.4.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyhcl/pyhcl-0.4.4.ebuild')
-rw-r--r--dev-python/pyhcl/pyhcl-0.4.4.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/pyhcl/pyhcl-0.4.4.ebuild b/dev-python/pyhcl/pyhcl-0.4.4.ebuild
deleted file mode 100644
index 99cbab7..0000000
--- a/dev-python/pyhcl/pyhcl-0.4.4.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="HCL configuration parser for python"
-HOMEPAGE="https://github.com/virtuald/pyhcl"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-RDEPEND=""
-BDEPEND="test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
-)"
-
-python_prepare_all() {
- sed -i -e "s/==.*$//" requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v || die
-}