summaryrefslogtreecommitdiff
path: root/dev-python/hvac/hvac-0.10.5.ebuild
diff options
context:
space:
mode:
authorGuillermo Ramos2020-11-06 21:58:22 +0100
committerGuillermo Ramos2020-11-06 22:01:02 +0100
commit9f8f71ca5d91d84d8817ae8c01e1678b163ffa2d (patch)
tree32ef5b20bd4da72fe8dc068803ae0e9e21157eac /dev-python/hvac/hvac-0.10.5.ebuild
parent66dbbe043e4a7e3a9aa1143937b90add8fa03068 (diff)
downloadgentoo-overlay-9f8f71ca5d91d84d8817ae8c01e1678b163ffa2d.tar.gz
Remove support for python2 in dev-python/* pkgs
Diffstat (limited to 'dev-python/hvac/hvac-0.10.5.ebuild')
-rw-r--r--dev-python/hvac/hvac-0.10.5.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/hvac/hvac-0.10.5.ebuild b/dev-python/hvac/hvac-0.10.5.ebuild
index a8f1847..c7b9243 100644
--- a/dev-python/hvac/hvac-0.10.5.ebuild
+++ b/dev-python/hvac/hvac-0.10.5.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
@@ -18,10 +18,12 @@ IUSE="test"
RDEPEND=">=dev-python/pyhcl-0.3.10[${PYTHON_USEDEP}]
>=dev-python/requests-2.21[${PYTHON_USEDEP}]
>=dev-python/six-1.5[${PYTHON_USEDEP}]"
-DEPEND="test? ( ${RDEPEND}
+BDEPEND="test? (
+ ${RDEPEND}
app-admin/vault
dev-python/nose[${PYTHON_USEDEP}]
- dev-python/semantic_version[${PYTHON_USEDEP}] )"
+ dev-python/semantic_version[${PYTHON_USEDEP}]
+)"
RESTRICT="test" # need running vault