summaryrefslogtreecommitdiff
path: root/dev-python/hvac/hvac-0.10.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hvac/hvac-0.10.5.ebuild')
-rw-r--r--dev-python/hvac/hvac-0.10.5.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/hvac/hvac-0.10.5.ebuild b/dev-python/hvac/hvac-0.10.5.ebuild
index a8f1847..c7b9243 100644
--- a/dev-python/hvac/hvac-0.10.5.ebuild
+++ b/dev-python/hvac/hvac-0.10.5.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
@@ -18,10 +18,12 @@ IUSE="test"
RDEPEND=">=dev-python/pyhcl-0.3.10[${PYTHON_USEDEP}]
>=dev-python/requests-2.21[${PYTHON_USEDEP}]
>=dev-python/six-1.5[${PYTHON_USEDEP}]"
-DEPEND="test? ( ${RDEPEND}
+BDEPEND="test? (
+ ${RDEPEND}
app-admin/vault
dev-python/nose[${PYTHON_USEDEP}]
- dev-python/semantic_version[${PYTHON_USEDEP}] )"
+ dev-python/semantic_version[${PYTHON_USEDEP}]
+)"
RESTRICT="test" # need running vault